githubの仕様変更に対応する

Pocket

昨日までちゃんとアクセスてきていたのですが,今日,git pushしようとするとエラーが発生。

ここに書いていました。SSLプロトコルはどうやら仕様から外れた模様。TLSにあげてくださいとのことです。

使っている大学のサーバのアプリケーションは古いモジュールが多く,OPENSSLもいまだに0.9.8のもの。相当古いです。。。

そこでインストールし直しますが,大学のサーバなので,ユーザ領域にインストールする必要があります。

環境

サーバ cray スパコン
ユーザ領域 /work/$USER

OpenSSL

ここを参考に,32bitモードでコンパイルします,これはいらないかも?

curl

git